HDU 1495 非常可乐
Description
大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出”NO”。
Input
三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以”0 0 0”结束。
Output
如果能平分的话请输出最少要倒的次数,否则输出”NO”。
Sample Input
7 4 3
4 1 3
0 0 0
Sample Output
NO
3
思路
六种倒水情况,a -> b, a -> c, b -> a, b -> c, c -> a, c -> b, BFS穷竭搜索
Code
#include <queue>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
int s, n, m;
struct node
{
int a, b, c, step;
};
bool vis[105][105][105];
int bfs()
{
node now;
now.a = s;
now.b = 0;
now.c = 0;
now.step = 0;
queue<node> q;
q.push(now);
vis[s][0][0] = 1;
while(q.size())
{
now = q.front();
q.pop();
if((now.a == 0 && now.b == now.c) || (now.b == 0 && now.a == now.c) || (now.c == 0 && now.a == now.b))
return now.step;
node nex;
int tra;///要转移的水
if(now.a)///a剩有部分水
{
tra = min(now.a, n - now.b);///a -> b 转移的水要么是a所剩,要么是b所缺
if(tra)///这部分 > 0 才可转移
{
nex.a = now.a - tra;
nex.b = now.b + tra;
nex.c = now.c;
nex.step = now.step + 1;
if(!vis[nex.a][nex.b][nex.c])
{
q.push(nex);
vis[nex.a][nex.b][nex.c] = 1;
}
}
tra = min(now.a, m - now.c);///a -> c
if(tra)
{
nex.a = now.a - tra;
nex.c = now.c + tra;
nex.b = now.b;
nex.step = now.step + 1;
if(!vis[nex.a][nex.b][nex.c])
{
q.push(nex);
vis[nex.a][nex.b][nex.c] = 1;
}
}
}
if(now.b)
{
tra = min(now.b, s - now.a);///b -> a
if(tra)
{
nex.b = now.b - tra;
nex.a = now.a + tra;
nex.c = now.c;
nex.step = now.step + 1;
if(!vis[nex.a][nex.b][nex.c])
{
q.push(nex);
vis[nex.a][nex.b][nex.c] = 1;
}
}
tra = min(now.b, m - now.c);///b -> c
if(tra)
{
nex.b = now.b - tra;
nex.c = now.c + tra;
nex.a = now.a;
nex.step = now.step + 1;
if(!vis[nex.a][nex.b][nex.c])
{
q.push(nex);
vis[nex.a][nex.b][nex.c] = 1;
}
}
}
if(now.c)
{
tra = min(now.c, s - now.a);///c -> a
if(tra)
{
nex.c = now.c - tra;
nex.a = now.a + tra;
nex.b = now.b;
nex.step = now.step + 1;
if(!vis[nex.a][nex.b][nex.c])
{
q.push(nex);
vis[nex.a][nex.b][nex.c] = 1;
}
}
tra = min(now.c, n - now.b);///c -> b
if(tra)
{
nex.c = now.c - tra;
nex.b = now.b + tra;
nex.a = now.a;
nex.step = now.step + 1;
if(!vis[nex.a][nex.b][nex.c])
{
q.push(nex);
vis[nex.a][nex.b][nex.c] = 1;
}
}
}
}
return 0;
}
int main()
{
while(~scanf("%d%d%d", &s, &n, &m) &&(s || n || m))
{
if(s & 1)///奇数不可能平分
cout << "NO" << '\n';
else
{
memset(vis, 0, sizeof(vis));
int ans = bfs();
if(ans)
cout << ans << '\n';
else
cout << "NO" << '\n';
}
}
return 0;
}