avatar
fireworks99
keep hungry keep foolish

POJ 2833 The Average

Description

In a speech contest, when a contestant finishes his speech, the judges will then grade his performance. The staff remove the highest grade and the lowest grade and compute the average of the rest as the contestant’s final grade. This is an easy problem because usually there are only several judges.

Let’s consider a generalized form of the problem above. Given n positive integers, remove the greatest n1 ones and the least n2 ones, and compute the average of the rest.

Input

The input consists of several test cases. Each test case consists two lines. The first line contains three integers n1, n2 and n (1 ≤ n1, n2 ≤ 10, n1 + n2 < n ≤ 5,000,000) separate by a single space. The second line contains n positive integers ai (1 ≤ ai ≤ 108 for all i s.t. 1 ≤ in) separated by a single space. The last test case is followed by three zeroes.

Output

For each test case, output the average rounded to six digits after decimal point in a separate line.

Sample Input

1 2 5

1 2 3 4 5

4 2 10

2121187 902 485 531 843 582 652 926 220 155

0 0 0

Sample Output

3.500000

562.500000

Hint

This problem has very large input data. scanf and printf are recommended for C++ I/O.

The memory limit might not allow you to store everything in the memory.

题意

给出n个数,去掉前n1个大的和前n2个小的,求平均值

思路

Hint里说了暴力会MLE,那就计算所有数字的和,vector存要去掉的n1 + n2个数字,最后减掉求平均值

题外话

数据量较大时,不能强行用较高精度的类型(例如:double)去存储较低精度的类型数值(例如:int), 在存储与计算时会TLE

Code

#include <cstdio>
#include <vector>
#include <iostream>
#include <algorithm>
using namespace std;

int main()
{
    int a, b, n;
    while(~scanf("%d%d%d", &a, &b, &n) && !(a == 0 && b == 0 && n == 0))
    {
        int s = a + b;
        vector<float> vec;
        double sum = 0;
        for(int i = 0; i < n; ++i)
        {
            int tem;
            scanf("%d", &tem);
            sum += tem;
            vec.insert(lower_bound(vec.begin(), vec.end(), tem), tem);
            if(vec.size() > s)
                vec.erase(vec.begin() + b);
            }
            for(int i = 0; i < vec.size(); ++i)
                sum -= vec[i];
            double ans = sum / (n - s);
            printf("%.6f\n", ans);
        }
        return 0;
    }
Site by Baole Zhao | Powered by Hexo | theme PreciousJoy