HDU 1231 最大连续子序列
Description
给定K个整数的序列{ N1, N2, …, NK },其任意连续子序列可表示为{ Ni, Ni+1, …, Nj },其中 1 <= i <= j <= K。最大连续子序列是所有连续子序列中元素和最大的一个, 例如给定序列{ -2, 11, -4, 13, -5, -2 },其最大连续子序列为{ 11, -4, 13 },最大和 为20。 在今年的数据结构考卷中,要求编写程序得到最大和,现在增加一个要求,即还需要输出该 子序列的第一个和最后一个元素。
Input
测试输入包含若干测试用例,每个测试用例占2行,第1行给出正整数K( < 10000 ),第2行给出K个整数,中间用空格分隔。当K为0时,输入结束,该用例不被处理。
Output
对每个测试用例,在1行里输出最大和、最大连续子序列的第一个和最后一个元 素,中间用空格分隔。如果最大连续子序列不唯一,则输出序号i和j最小的那个(如输入样例的第2、3组)。若所有K个元素都是负数,则定义其最大和为0,输出整个序列的首尾元素。
Sample Input
6
-2 11 -4 13 -5 -2
10
-10 1 2 3 4 -5 -23 3 7 -21
6
5 -8 3 2 5 0
1
10
3
-1 -5 -2
3
-1 0 -2
0
Sample Output
20 11 13
10 1 4
10 3 5
10 10 10
0 -1 -2
0 0 0
思路
dp[i]表示以i结尾的最大连续子序列的和 (也可以直接以数学思维做)
Code(动态规划)
#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;
int main()
{
int n;
while(cin >> n && n)
{
long long a[10005];
long long dp[10005];
bool flag = 0;
for(int i = 0; i < n; ++i)
{
scanf("%lld", &a[i]);
if(a[i] >= 0)
flag = 1;
}
if(!flag)
{
cout << '0' << ' ' << a[0] << ' ' << a[n - 1] << '\n';
continue;
}
int mmax = -1;///为了不漏0
int start = 0;
int over = 0;
///dp的时候注意第一个的初始化
dp[0] = a[0];
if(dp[0] > mmax)
{
mmax = dp[0];
over = 0;
}
for(int i = 1; i < n; ++i)
{
dp[i] = max(dp[i - 1] + a[i], a[i]);
if(dp[i] > mmax)
{
mmax = dp[i];
over = i;
}
}
///找最靠前的start
int tem = mmax;
for(int i = over; i >= 0; --i)
{
tem -= a[i];
if(tem == 0)
start = i;
}
cout << mmax << " " << a[start] << " " << a[over] << '\n';
}
}
数学思维 https://blog.csdn.net/chikchen/article/details/84501429