avatar
fireworks99
keep hungry keep foolish

HDU 1232 畅通工程

关于并查集

并查集,在一些有N个元素的集合应用问题中,我们通常是在开始时让每个元素构成一个单元素的集合,然后按一定顺序将属于同一组的元素所在的集合合并,其间要反复查找一个元素在哪个集合中。

特点是看似并不复杂,但数据量极大 。

是一种树型的数据结构,用于处理一些不相交集合(Disjoint Sets)的合并及查询问题 。

Description

某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?

Input

测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。 注意:两个城市之间可以有多条道路相通,也就是说

3 3

1 2

1 2

2 1 这种输入也是合法的 当N为0时,输入结束,该用例不被处理。

Output

对每个测试用例,在1行里输出最少还需要建设的道路数目。

Sample Input

4 2
1 3
4 3
3 3
1 2
1 3
2 3
5 2
1 2
3 5
999 0
0

Sample Output

1
0
2
998

Code

#include <cstdio>
#include <iostream>
using namespace std;
const int N = 1005;

int pre[N];
int n, m, ans;

void init()
{
    ans = n - 1;
    for(int i = 0; i <= n; ++i)///初始化顶级是自身
        pre[i] = i;
}

int found(int x)
{
    if(x != pre[x])///顶级不是自身
        pre[x] = found(pre[x]);///找的过程中顺带优化(压缩路径)
    return pre[x];
}

void unite(int a, int b)///联合
{
    int x = found(a);
    int y = found(b);
    if(x != y)
    {
        pre[x] = y;///此题pre[y] = x亦可
        ans--;
    }
    return ;
}

int main()
{
    int there, here;
    while(~scanf("%d", &n) && n)
    {
        scanf("%d", &m);
        init();
        for(int i = 0; i < m; ++i)
        {
            scanf("%d%d", &there, &here);
            unite(there, here);
        }
        cout << ans << '\n';
    }
    return 0;
}

非递归版found函数

int found(int x)
{
    ///寻找根节点(最终顶级、最终祖先)
    int root = x;
    while(root != pre[root])///根节点特点:顶级是自身
        root = pre[root];

    ///路径压缩
    int now = x;
    while(now != root)///将路径上所有点的顶级改为根节点(root)
    {
        int nxt = pre[now];
        pre[now] = root;
        now = nxt;
    }
    return root;
}
Site by Baole Zhao | Powered by Hexo | theme PreciousJoy