HDU 1874 畅通工程续
Dijkstra算法
主要特点是以起始点为中心向外层层扩展(广度优先搜索思想),直到扩展到终点为止。
主要思想是每次找到离”已成图“最近的一个顶点,然后将该顶点连入图,然后更新“已成图”到其他顶点的最短路径。贪心算法。
该算法要求图中不存在负权边!!!(无负权边自然无负权环)
更多关于Dijkstra算法过程 https://blog.csdn.net/wenqiang1208/article/details/76473984
Bellman-Ford算法
原理是对图进行V-1次松弛操作,得到所有可能的最短路径。其优于迪科斯彻算法的方面是边的权值可以为负数、实现简单,缺点是时间复杂度过高,高达O(VE)。但算法可以进行若干种优化,提高了效率。
可有负权边,可判负权环。(突出特点!)
更多关于Bellman-Ford算法过程 https://blog.csdn.net/a8082649/article/details/81812000
Floyd算法
Floyd-Warshall算法(Floyd-Warshall algorithm)是解决任意两点间的最短路径的一种算法,可以正确处理有向图或负权的最短路径问题 (ye可判负权环!!!)
注意点是从 0 ~ n-1 还是 1 ~ n
更多关于Floyd算法 https://www.cnblogs.com/GumpYan/p/5540549.html
Description
某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。 现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。
Input
本题目包含多组数据,请处理到文件结束。 每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。 接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。 再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。
Output
对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.
Sample Input
3 3
0 1 1
0 2 3
1 2 1
0 2
3 1
0 1 1
1 2
Sample Output
2
-1
Code of Dijkstra
#include <queue>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int N = 100005;
const int inf = 0x3f3f3f3f;
struct node///存放“边”
{
int from, to, w, pre;
} a[N];
///n为点的个数,dis[i]表示从起点到点i目前最短路径
int head[N], cnt, dis[N], times[N], n, m;
bool vis[N];
void init()
{
cnt = 0;
for(int i = 0; i <= n; ++i)
dis[i] = inf, times[i] = 0, vis[i] = 0, head[i] = -1;
return ;
}
void add(int from, int to, int w)
{
a[cnt].from = from;
a[cnt].to = to;
a[cnt].w = w;
a[cnt].pre = head[from];
head[from] = cnt;
cnt++;
a[cnt].from = to;
a[cnt].to = from;
a[cnt].w = w;
a[cnt].pre = head[to];
head[to] = cnt;
cnt++;
}
void dijkstra(int start)
{
dis[start] = 0;
int now_pos = start;
while(now_pos != -1)
{
for(int i = head[now_pos]; ~i; i = a[i].pre)
{
if(vis[ a[i].to ])
continue;
///最短路核心体现:起点到某点(a[i].to)距离 > 起点经由此点(now_pos)到该点(a[i].to)距离就更新
if(dis[ a[i].to ] == inf || dis[ a[i].to ] > dis[now_pos] + a[i].w)
dis[ a[i].to ] = dis[now_pos] + a[i].w;
}
vis[now_pos] = 1;
int mmin = -1;
now_pos = -1;
for(int i = 0; i < n; ++i)///遍历 0 ~ n - 1 这些点
{
if(!vis[i] && dis[i] != inf && (dis[i] < mmin || mmin == -1 ))
{
mmin = dis[i];
now_pos = i;
}
}
}
return ;
}
int main()
{
while(~scanf("%d%d", &n, &m))
{
init();
int b, c, d;
int tem = m;
while(tem--)
{
scanf("%d%d%d", &b, &c, &d);
add(b, c, d);
}
int start, over;
scanf("%d%d", &start, &over);
dijkstra(start);
if(dis[over] != inf)
cout << dis[over] << '\n';
else
cout << "-1" << '\n';
}
return 0;
}
Code of Bellman-Ford
#include <queue>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int N = 100005;
const int inf = 0x3f3f3f3f;
struct node///存“边”
{
int from, to, w;
} a[N];
int n, m, cnt, dis[N];
void add(int from, int to, int w)
{
a[cnt].from = from;
a[cnt].to = to;
a[cnt].w = w;
cnt++;
a[cnt].from = to;
a[cnt].to = from;
a[cnt].w = w;
cnt++;
}
bool Bellman_Ford(int start)
{
dis[start] = 0;
int tot = n;
while(tot--)
{
bool flag = 0;///优化
for(int i = 0; i < cnt; ++i)
if(dis[ a[i].to ] > dis[ a[i].from ] + a[i].w)
{
flag = 1;
dis[ a[i].to ] = dis[ a[i].from ] + a[i].w;
}
if(flag == 0)
break;
}
for(int i = 0; i < cnt; ++i)///判负权环(负权回路)
if(dis[ a[i].to ] > dis[ a[i].from ] + a[i].w)
return 0;
return 1;
}
int main()
{
while(~scanf("%d%d", &n, &m))
{
memset(dis, inf, sizeof(dis));
cnt = 0;
int b, c, d;
int tem = m;
while(tem--)
{
scanf("%d%d%d", &b, &c, &d);
add(b, c, d);
}
int start, over;
scanf("%d%d", &start, &over);
if(Bellman_Ford(start))
{
if(dis[over] != inf)
cout << dis[over] << '\n';
else
cout << "-1" << '\n';
}
}
return 0;
}
Code of Floyd
#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;
const int inf = 0x3f3f3f3f;
int n, m;
int e[210][210];
void floyd()
{
///注意点是从 0 ~ n-1 还是 1 ~ n
for(int k = 0; k < n; ++k)
for(int i = 0; i < n; ++i)
for(int j = 0; j < n; ++j)
if(e[i][j] > e[i][k] + e[k][j])
e[i][j] = e[i][k] + e[k][j];
}
int main()
{
while(cin >> n >> m)
{
///注意点是从 0 ~ n-1 还是 1 ~ n
for(int i = 0; i < n; ++i)
for(int j = 0; j < n; ++j)
e[i][j] = (i == j ? 0 : inf);
int from, to, w;
for(int i = 0; i < m; ++i)
{
cin >> from >> to >> w;
if(e[from][to] > w)
e[from][to] = e[to][from] = w;
}
int start, over;
cin >> start >> over;
floyd();
if(e[start][over] == inf)
cout << "-1" << '\n';
else
cout << e[start][over] << '\n';
}
return 0;
}